[PT4] Błąd instalacji PostgreSQL

    • matexide
      matexide
      Brąz
      na forum od: 26.06.2010 Posty: 601
      Witam. Sciągnąłem ze strony Pokertracker nowy PT4, zainstalowałem, przy pierwszym odpaleniu ( oczywiscie jako admin) instaluje mi baze PostgreSQL i po zakończeniu instalacji pokazuje komunikat, że program nie został pomyślnie zainstalowany.Przy próbie odpalenia, nie może połączyć się z serwerem. Próbowałem też oddzielnie zainstalować to ze stronki podanej przez kogoś w podobnym temacie, na oddzielnym dysku i też to samo.. Mam Vistę, kiedyś używałem PT3 i wszystko było ok. Co z tym zrobić?
  • 18 odpowiedzi
    • kapelusznik
      kapelusznik
      Brąz
      na forum od: 12.01.2009 Posty: 18 046
      Jaka wersja PostgreSQL? PT4 nie współpracuje z nowymi wersjami.
    • maciasowy
      maciasowy
      Brąz
      na forum od: 01.01.2011 Posty: 1 253
      Ostatnia współpracująca to Version 9.0.13 chyba że coś się zmieniło
    • matexide
      matexide
      Brąz
      na forum od: 26.06.2010 Posty: 601
      Program sam mi instaluje automatycznie wersję po odpaleniu programy (PT4), więc chyba by nie sciągało złej wersji...
      edit. a ta wersja którą sam instalowalem manualnie to wlasnie to co niby ma dzialas z PT4
    • maciasowy
      maciasowy
      Brąz
      na forum od: 01.01.2011 Posty: 1 253
      Wyłączyłeś UAC i masz service packi zainstalowane do Visty?

      http://www.pokertracker.com/guides/PT4/databases/how-to-uninstallmanually-install-postgresql-90-windows#microsoft-windows-vista-windows-7-users
    • matexide
      matexide
      Brąz
      na forum od: 26.06.2010 Posty: 601
      Tak, UAC wyłączony, service packi też. Ciągle to samo, nie może zakończyć instalacji poprawnie, przez co później nie może się połączyć..tak to wygląda:
      "Problem running post-install step. Instalation may not complete corectly. Error reading file D:/data/postgresql.conf
    • maciasowy
      maciasowy
      Brąz
      na forum od: 01.01.2011 Posty: 1 253
      Przeskanuj rejestr jakimś programem do czyszenia rejestru i sprawdź czy nie masz błędów na dysku. Może tu jest problem
    • matexide
      matexide
      Brąz
      na forum od: 26.06.2010 Posty: 601
      Czyściłem CCleanerem, zainstalowałem starszą wersję ( 8.4) i tu też problem z instalacją. Przy odpaleniu pojawia się natomiast komunikat:
      "could not connect to server:connection refused(0x0000274D/10061) Is the server running on host "localhost" and accepting TCPT/IP connection on port 5432?"
      na stronie pokertracker niby też opisują ten problem, ale jak postąpiłem według ich wskazówek, nic nie dało..
      Chyba sobie daruję tego trackera...
    • spinek
      spinek
      SuperModerator
      SuperModerator
      na forum od: 27.09.2009 Posty: 5 894
      Cześć matexide,

      Spróbuj zainstalować wersję, którą chcesz np. 9.0.13 z tej strony tylko wybierz inny folder instalacji niż domyślny np. c:/postgresql

      Daj znać czy się zainstaluje. Jeżeli wystąpią błędy, daj znać jakie.

      Pozdrawiam
    • matexide
      matexide
      Brąz
      na forum od: 26.06.2010 Posty: 601
      Właśnie z tej strony ( znalazłem w innym temacie) instalowałem. Jak mówiłem, na innym dysku. Błąd taki jak w moim poprzednim poście.

      Edit. Pod koniec instalacji wyświetla mi taki błąd:
      "a non-fatal error occured whilst loading database modules. Please check the installation log in C:/users/.../appdata/local/temp for details"

      I chwilę później:
      "problem running post-install step. Error reading file: D:/programs/data/postgresql.conf"
    • spinek
      spinek
      SuperModerator
      SuperModerator
      na forum od: 27.09.2009 Posty: 5 894
      Hej,

      Odinstaluj jeszcze raz postgreSQL z Panelu Sterowania i wykonaj z Wiersza Poleceń (jako administrator) polecenie:
      net user postgres /delete

      Potem spróbuj zainstalować ponownie w innej lokalizacji.

      Nie masz przypadkiem nazwy użytkownika w Windows z polskimi znakami? To również powoduje problemy z instalacją postgreSQL.

      Pozdrawiam
    • matexide
      matexide
      Brąz
      na forum od: 26.06.2010 Posty: 601
      Odinstalowalem, wykasowalem net user postgres tak jak radziłeś. Instalka w innej lokalizacji i znowu to samo :( . W nazwie użytkownika nie mam polskich znaków.
    • spinek
      spinek
      SuperModerator
      SuperModerator
      na forum od: 27.09.2009 Posty: 5 894
      Niefajnie :(
      Ewentualnie możesz spróbować jeszcze utworzyć odpowiednie foldery i nadać im uprawnienia zgodnie z 7 punktem FAQ, ale nie wiem czy to pomoże.

      Spróbuj też instalować różne wersje postgreSQL, bo niektóre się nie chcą dać zainstalować, a czasem jakaś starsza przejdzie.

      A jak nic nie pomoże, to pozostaje kontakt z supportem PT4. Gdyby coś poradzili i w końcu udało Ci się zainstalować, to daj znać. Będziemy mądrzejsi. Mi niestety kończą się pomysły :(

      Pozdrawiam
    • matexide
      matexide
      Brąz
      na forum od: 26.06.2010 Posty: 601
      Z tym ustawianiem uprawnień próbowałem wcześniej, ale w ogóle wtedy nie chciałozacząć instalacji bo był błąd, że folder nie jest pusty czy jakoś tak. Maila do PT4 napisałem, jak coś odpiszą to się tu podzielę. Próbowałem już chyba wszystkie wersje. Jutro siądę na spokojnie raz jeszcze poszukam w necie, może ktoś miał ten sam problem i jakoś się udało wybrnąć.
      Ps. Czy jak kiedyś używałem pokertrackera 3 ( a więc też postgresql) to może być przez to problem? To było dawno i po tym bylo kilka formatów na kompie więc chyba raczej nie?

      EDIT:
      czy da się jakoś manualnie w tym programie pgAdminIII ustawić, żeby działało? Jakbym nie próbował wyświetla mi to:
      "The server doesn't accept connections: the connection library reports
      could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" and accepting TCP/IP connections on port 5432? could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" and accepting TCP/IP connections on port 5432? "
      Nawet jak mam wyłączoną zaporę.. Nie wiem już, co z tym zrobić.
    • matexide
      matexide
      Brąz
      na forum od: 26.06.2010 Posty: 601
      Wklejam rozwiązanie, jakie otrzymałem z supportu PT4. Może się komuś jeszcze przydać. U mnie zadziałało:)

      1. Reboot.

      2. Check that your Windows "Secondary Login" service is running. You can check/manually start it by clicking "Start -> Control Panel -> Administrative Tools -> Services".

      Find "Secondary Logon" in the list, double-click it and make sure that it's set to "Automatic" startup type. Also, press "Start" to manually start the service if needed.

      3. Uninstall "PostgreSQL" from "Control Panel -> Programs and Features" if it's there.

      Click "Start -> All Programs -> Accessories", right-mouse-button on "Command Prompt", select "Run as administrator" and copy/paste this in the window (then press the "enter" key):


      net user postgres /delete

      This could fail but should be ok.

      4. With "Start -> All Programs -> Accessories -> Windows Explorer" check both of these locations for a "PostgreSQL" folder and rename it to "PostgreSQL_ORIG" if found:

      C:\Program Files

      C:\Program Files (x86)

      If you don't find a "PostgreSQL" folder that may be ok.

      5. Download this PostgreSQL installer: http://ftp.postgresql.org/pub/binary/v8.3.23/win32/postgresql-8.3.23-1.zip

      You'll need a free compression program like "winzip" or "winrar" if you're unable to double-click what you downloaded and it won't open.

      6. Once you can open the file, extract the contents somewhere such as your desktop. Double-click the file "postgresql-8.3.msi" (not "postgresql-8.3-int.msi"). Make sure to not try to run that file from within the decompression tool.

      At the start you should see a "Write detailed..." at the bottom, put a check mark in that.

      Choose your language and click "Start", "Next", "Next", "Next" until you reach "Service Configuration" window.

      In each password box type "svcPASS83" (no quotes) and click "Next".

      Answer "Yes" to "create account?"

      Answer "No" to "replace it with a random password?"

      In the next window type "dbpass" (no quotes) in both password boxes.

      Click "Next" and "Next" and wait for it to finish.

      Near the end of the PostgreSQL install remove the check mark from the "Stackbuilder" option and click "Finish".

      This next step (#7) has two parts, one if the PostgreSQL install finished (#7A) and one if it didn't (#7B) - you should only need to do one of them depending on which happened:

      7A) If the PostgreSQL install finished click "All Programs -> PokerTracker 4 -> PokerTracker 4 (Logging Enabled)" and use these settings in the "Configure PostgreSQL" window:

      server localhost
      port 5432
      user postgres
      password dbpass

      If things work you should be all set but if not attach to your reply:

      --> C:\Users\some_name\AppData\Local\PokerTracker 4\PokerTracker4.log

      --> The newest 1 or 2 PostgreSQL logs from here:

      C:\Program Files\PostgreSQL\8.3\data\pg_log

      or here:

      C:\Program Files (x86)\PostgreSQL\8.3\data\pg_log

      7B) But if the PostgreSQL install failed we need to see why so from the folder you started the manual install from, look for the PostgreSQL installation log. That's what to send us.
    • spinek
      spinek
      SuperModerator
      SuperModerator
      na forum od: 27.09.2009 Posty: 5 894
      Dzięki za info! Najważniejsze, że się udało i wreszcie działa :s_thumbsup:
      Gdy ktoś będzie miał podobny problem, będę mógł go skierować do podanego przez support PT4 rozwiązania.

      Pozdrawiam
    • emomaniac
      emomaniac
      Brąz
      na forum od: 11.08.2006 Posty: 2 420
      Dodam jeszcze, że ostatnio miałem do rozwiązania podobny problem - sprawa rozbijała się o uprawnienia. Sprawa dotyczy WIN 7 32 bit i pewnie Visty - w tych OSach nie można zmieniać uprawnień folderom w "program files" - wystarczy zainstalować np w C:\PostgreSql , a bazę dalej tak jak pokazuje instalator.
    • Rumunus
      Rumunus
      Brąz
      na forum od: 14.08.2011 Posty: 703
      Podepnę się do tematu. Mam problem w tym punkcie. Jak to ustawić na windows 8 PL bo nie mogę znaleźć

      2. Check that your Windows "Secondary Login" service is running. You can check/manually start it by clicking "Start -> Control Panel -> Administrative Tools -> Services".Find "Secondary Logon" in the list, double-click it and make sure that it's set to "Automatic" startup type. Also, press "Start" to manually start the service if needed.
    • Skibcio
      Skibcio
      Head admin
      Head admin
      na forum od: 03.11.2010 Posty: 9 539
      Witaj Rumunus,

      Secondary logon to logowanie pomocnicze.

      Pozdrawiam.