[HM2] Baza danych PostgreSQL

    • masterekk
      masterekk
      Brąz
      na forum od: 14.11.2010 Posty: 36
      Witam serdecznie,


      Przejdę od razu do rzeczy - posiadam Windows 8 64bit, komp świeży ponieważ zakupiony około 2 tygodnie temu, więc żadna baza danych nie była na nim wcześniej instalowana.

      Podczas combo instalacji z HM wywala błąd: "Sorry, could not install SQL"

      Podczas instalacji tylko bazy danych wywala błąd: "Problem running post-install step. Installation may not complete correctly Error reading file: C:/Program Files/PostgreeSQL/8.4/data/postgresql.conf"

      Instalowałem również w innym folderze, aby wyeliminować spację w ścieżce.
      Próbowałem z wersją 8.4/9.0/9.2

      Dodam również, że robiłem wszystko zgodnie z postem imgoingtomirage z tego tematu bez powodzenia niestety: 1. Instalacja 2. Co z PostgreSQL

      Podczas instalacji uruchamiałem jako admin, wyłączałem nortona.
      Ustawienie zgodności z windowsem 7 lub xp również bez efektów.


      Jakieś sugestie co mógłbym jeszcze zrobić? :rage:
  • 3 odpowiedzi
    • spinek
      spinek
      SuperModerator
      SuperModerator
      na forum od: 27.09.2009 Posty: 5 931
      Hej masterekk,

      No niestety czasem Postgresql się nie chce zainstalować :(
      W Windows 8 sporo z tym problemów bywa.

      Ciężko tak poprzez forum zlokalizować problem, ale podrzucę Ci parę linków, gdzie może znajdziesz coś pomocnego:
      post z forum HM2 - co prawda dotyczy Windows7, ale jest parę rzeczy, na które warto zwrócić uwagę
      upgrade do Windows 8 - niezbyt to pomocne, ale może coś znajdziesz
      Jak zainstalować bazę "ręcznie" - wersję PostgreSQL możesz zmienić. Posłużenie się tym tematem wymaga trochę wiedzy.

      I jeszcze jedna propozycja (może trochę dziwna :D ): spróbuj zainstalować trial PokerTrackera 4. Nie wiem czy kiedyś nie słyszałem o przypadku, że komuś w ten sposób udało się zainstalować PostgreSQL, potem odinstalował PT4, zainstalował HM2 i podłączył się do tak zainstalowanej bazy.

      Pozdrawiam
    • masterekk
      masterekk
      Brąz
      na forum od: 14.11.2010 Posty: 36
      Siemanko spinek!

      Bardzo dziękuje za rady,

      Walczyłem po moim pierwszym poście z tym Postgresql jeszcze z kilka dni :facepalm:

      Na szczęście rozgryzłem w czym tkwi problem... co ciekawe był banalny...

      Intuicyjnie skupiłem się na tym, że coś nie pasuje w ścieżce. Pomyślałem, że Postgresql nie odpowiadała nazwa użytkownika "Łukasz", a konkretnie polski znak w ścieżce instalacyjnej....

      Niestety sama zmiana nazwy użytkownika na inne słowo (bez polskich znaków) nie pomogła, ponieważ user w windowsie w dysku C zostawał pod taką samą nazwą jaką nadało się podczas pierwszego zalogowania.

      Skończyło się na reinstalacji windowsa... :D i nadaniu właściwej nazwy usera już na samym początku. Oczywiście po tym zabiegu HM wraz z bazą zainstalował się bez najmniejszego problemu :)

      Z tego miejsca chciałbym pozdrowić wszystkich o imieniu Łukasz/Paweł/Sławek itd. Jeśli ktoś będzie miał podobny problem i polski znak w nazwie usera to zna już przyczynę :)

      Pozdro !
    • spinek
      spinek
      SuperModerator
      SuperModerator
      na forum od: 27.09.2009 Posty: 5 931
      Hej masterekk,

      Kilka miesięcy temu miałem ten sam problem :facepalm:
      Nie wiem co mnie podkusiło, ale też stworzyłem usera z polskimi znakami i musiałem reinstalować system. Co prawda jakieś tam sposoby obejścia tego są, ale raczej skomplikowane, a skoro miałem świeży system to szybciej wyszedł format C: :)

      Najważniejsze, że w końcu znalazłeś przyczynę i wszystko dziala :f_thumbsup:

      Pozdrawiam, też mam "Ł" w imieniu ;)